Вопрос по информатике:
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.
- 04.06.2018 21:16
- Информатика
- remove_red_eye 19240
- thumb_up 32
Ответы и объяснения 1
Const
n = 5;
var
a,b : array [1..n] of integer;
i,s,k1,k2,max,min : integer;
begin
for i := 1 to n do
readln (a[i]);
for i := 1 to n do
writeln (i,')elem = ',a[i]);
end.
begin
for i := 1 to n do
a[i] := i * 3;
for i := 1 to n do
writeln (i,')elem = ',a[i]);
end.
begin
s := 0;
for i := 1 to n do
begin
readln (a[i]);
s := s + a[i];
end;
writeln (s);
end.
begin
k1 := 0;
k2 := 0;
for i := 1 to n do
begin
readln (a[i]);
if a[i] > 0 then
k1 := k1 +1;
if a[i] < 0 then
k2 := k2 +1;
end;
writeln ('+ ',k1);
writeln ('- ',k2);
end.
begin
k1 := 0;
k2 := 0;
for i := 1 to n do
begin
readln (a[i]);
if (a[i] > 0) and (i mod 2 = 1) then
k1 := k1 +1;
if (a[i] < 0) and (i mod 2 = 0) then
k2 := k2 +1;
end;
writeln ('+ ',k1);
writeln ('- ',k2);
end.
begin
for i := 1 to n do
begin
readln (a[i]);
if a[i] < 0 then
b[i] := sqr (a[i]);
if a[i] > 0 then
b[i] := a[i] * a[i] * a[i];
end;
for i := 1 to n do
write (a[i],' ');
writeln ();
for i := 1 to n do
write (b[i],' ');
end.
begin
for i := 1 to n do
readln (a[i]);
max := a[1]; min := a[1];
for i := 2 to n do
begin
if a[i] > max then
max := a[i];
if a[i] < min then
min := a[i];
end;
writeln ('max=',max);
writeln ('min=',min);
end.
begin
for i := 1 to n do
readln (a[i]);
writeln ('found :');
readln (s);
k1 := 0; k2 := 0;
for i := n downto 1 do
if a[i] = s then
begin
k1 := k1 + 1;
k2 := i;
end;
writeln ('k=',k1);
writeln ('i=',k2);
end.
Бери те переменные, которые используются в конкретной программме.
- 05.06.2018 14:15
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.