Вопрос по информатике:
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали.
Входные данные
В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) ( 1 ≤ N ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по N натуральных чисел, разделённых пробелами.
Выходные данные
Программа должна вывести матрицу, у которой все элементы выше главной диагонали нулевые, а остальные элементы такие же, как в исходной матрице.
- 14.09.2017 23:49
- Информатика
- remove_red_eye 8512
- thumb_up 21
Ответы и объяснения 1
Program obnulenie;
var a:array[1..100,1..100] of integer;
i,j,n:integer;
begin
writeln('Введите размер квадратной матрицы:');
readln(n);
writeln('Введите матрицу:');
for i:=1 to n do
for j:=1 to n do
begin
read(a[i,j]);
if j>i then a[i,j]:=0;
end;
writeln('Измененная матрица:');
for i:=1 to n do
begin
for j:=1 to n do
write(a[i,j],' ');
writeln;
end;
end.
- 15.09.2017 03:13
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.