Вопрос по информатике:
Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел.
нужно составить блок-схему для этой задачи.
- 11.06.2018 04:43
- Информатика
- remove_red_eye 14301
- thumb_up 14
Ответы и объяснения 2
Pascal
var
a,s, r : real;
i : integer;
begin
for i := 1 to 10 do
begin
readln (a);
s := s +a;
end;
r := s/r;
writeln ('sr=',r:3:2);
writeln ('s=',s:3:2);
end.
- 12.06.2018 17:59
- thumb_up 40
Var
i:integer;
a,sum,s:real;
begin
for i:=1 to 10 do
begin
read(a);
sum:=sum+a;
end;
write('Сумма: ',sum);
s:=s/10;
write('Cреднее арифметическое: ',s);
end.
- 13.06.2018 16:50
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.