Вопрос по информатике:
3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количе-ство замен. Протестировать программу на следующих исходных данных:
а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15
б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4
НА ПАСКАЛЕ
- 14.09.2017 20:39
- Информатика
- remove_red_eye 5707
- thumb_up 7
Ответы и объяснения 1
Var i,j,z,n,count:integer;
var a:array[1..1000] of integer;
begin
writeln('Введите Z: ');
readln(z);
writeln('Введите N: ');
readln(n);
writeln('Введите N чисел через пробел: ');
count:=0;
for i:=1 to n do begin
read(j);
if j<=z then a[i]:=j
else begin a[i]:=z; count:=count+1; end;
end;
writeln('Количество замен: ',count);
write('Полученный массив: ');
for i:=1 to n do write(a[i], ' ');
end.
- 15.09.2017 04:45
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.