Вопрос по информатике:
Решить не могу задачи по информатике:
1. Составьте программу ввода элементов массива h [1..8] с клавиатуры и вывода на экран элементов с отрицательными значениями.
2.Составьте программу, которая заполняет массив h [1..10] случайными целыми числами в диапазоне от -10 до 10 и находит количество элементов с отрицательными значениями.
3. Составьте программу, которая заполняет массив h [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечётными значениями и количество элементов с нечётными значениями.
5. Составьте программу, которая заполняет массив h [1..20] случайными целыми числами в диапазоне от 1 до 20 и находит среднее арифметическое элементов кратных трём и чётными индексами.
- 17.11.2017 03:34
- Информатика
- remove_red_eye 7782
- thumb_up 6
Ответы и объяснения 1
1)var h:array[1..8]of integer;
i:integer;
begin
write('massiv');
for i:=1 to 8 do
read(h[i]);
writeln;
write('elementi s otric znach');
for i:=1 to 8 do
if h[i]<0 then write(h[i],' ');
end.
2)var h:array[1..10]of integer;
i,k:integer;
begin
write('massiv:');
for i:=1 to 10 do
begin
h[i]:=random(21)-10;
write(h[i],' ');
end;
writeln;
for i:=1 to 10 do
if h[i]<0 then k:=k+1;
write('kol-vo elem s otric znach:',k);
end.
3)var h:array[1..10]of integer;
i,k,p:integer;
begin
write('massiv:');
for i:=1 to 10 do
begin
h[i]:=random(10)+1;
write(h[i],' ');
end;
writeln;
p:=1;
for i:=1 to 10 do
if h[i] mod 2=1 then
begin
k:=k+1;
p:=p*h[i];
end;
write('kol-vo elem s nechet znach:',k,' proizvedenie:',p);
end.
5)var h:array[1..20]of integer;
i,k,s:integer;
a:real;
begin
write('massiv:');
for i:=1 to 10 do
begin
h[i]:=random(20)+1;
write(h[i],' ');
end;
writeln;
for i:=1 to 10 do
if (h[i] mod 3=0)and(i mod 2=0) then
begin
k:=k+1;
s:=s+h[i];
end;
a:=s/k;
write('srednee arifmet:',a);
end.
- 18.11.2017 20:25
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.