Вопрос по информатике:
Написать программу в Паскале, которая вычислит все двузначные числа,сумма цифр которых равна 12. Только , как можно проще. Алгоритм вычисления пожалуйста пришлите.
- 15.03.2018 09:29
- Информатика
- remove_red_eye 3188
- thumb_up 25
Ответы и объяснения 1
Var
a,a1,a2:integer;
Begin a:=10;
Write('Двузначные числа, сумма цифр которого равна 12: ');
while a<100 do
begin
a1:=a mod 10;
a2:=a div 10;
if (a1+a2)=12 then write(a,', ');
a:=a+1;
end;
End.
- 16.03.2018 11:38
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.