Вопрос по информатике:
Написать программу,позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.Длина массива N задается пользователем как константное выражение.Исходные данные задать вручную или с помощью генератора случайных чисел,учитывая формат элементов массива А.Тип результата определяется из контекста.
-Вычислить количество отрицательных элементов массива;
-сумму модулей элементов массива,расположенных после максимального элемента
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 24.03.2015 21:38
- Информатика
- remove_red_eye 19917
- thumb_up 11
Ответы и объяснения 1
Const n=
var a:array [1..n] of integer; (целый)
i,k, i_max: byte; max, sum:integer;
begin
randomize; или for i:=1 to n do
for i:=1 to n do readln(a[i]);
a[i]:=random (100);
k:=0
for i:=1 to n do
if a[i]<0 then k:=k+1];
max:=0; i_max:=0;
for i:=1 to n do
if a[i]>max then begin max:=a[i]; i_max:=i; end;
sum:=0;
for i:=i_max to n do
sum:=sum+a[i];
writeln('Количество отрицательных элементов ',k);
writeln('Сумма элементов ', sum);
readln;
end.
- 25.03.2015 15:26
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.