Вопрос по информатике:
Написать программу для Pascal ABC.Дан массив действительных чисел,размерность которого N.Подсчитать,сколькоив нем отрицательных,положительных и нулевых элементов.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 04.11.2015 09:57
- Информатика
- remove_red_eye 14292
- thumb_up 49
Ответы и объяснения 1
Program aaa;
var
a,b,c,n,i:longint;
M:array[1..1000000] of real;
begin
read(n); //
for i:=1 to n do //если считывать массив не нужно, то удалить
read(M[i]); //
a:=0;
b:=0;
c:=0;
for i:=1 to n do
begin
if M[i]>0 then inc(a);
if M[i]=0 then inc(b);
if M[i]<0 then inc(c)
end;
writeln('положительных элементов:',a);
writeln('нулевых элементов:',b);
writeln('отрицательных элементов:',c)
end.
- 05.11.2015 15:22
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.