Вопрос по информатике:
Написать программу, которая запрашивает у пользователя номер товара и выводит его название (не менее 5 товаров). Если пользователь указывает недопустимое число, то выво-дится сообщение «Ошибка ввода данных»
- 11.02.2016 12:38
- Информатика
- remove_red_eye 16196
- thumb_up 23
Ответы и объяснения 1
type goods = record name:String; price:real; end;const GOODS_COUNT = 5;var goodsList:array[1..GOODS_COUNT] of goods;id:integer;begin goodsList[1].name:='iPhone 5s'; goodsList[1].price:=760.0; goodsList[2].name:='Samsung Galaxy s5'; goodsList[2].price:=540.0; goodsList[3].name:='Simens m60'; goodsList[3].price:=12.5; goodsList[4].name:='HTC ONE X'; goodsList[4].price:=450.5; goodsList[5].name:='LG L9'; goodsList[5].price:=600.0; write('Write goods id:'); readln(id); if ( ( id GOODS_COUNT ) ) then writeln('WRONG ID') else writeln(goodsList[id].name,' price =',goodsList[id].price); end.
- 12.02.2016 21:03
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.