Вопрос по информатике:
1. Составьте программу, выясняющую, есть ли в словах Х и У одинаковые символы.
2. Составьте программу, удваивающую в слове Х буквы "б" и "а".
- 23.01.2018 06:06
- Информатика
- remove_red_eye 15589
- thumb_up 32
Ответы и объяснения 1
#include
#include
#include
int main()
{
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
std::string x, y;
std::cin >> x >> y;
//1
bool same= false;
for (auto i : x){
for (auto j : y){
if (i == j) {same = true; break;}
}
if (same) break;
}
std::cout << std::boolalpha << same;
//2
for (unsigned int i = 0; i < x.size(); ++i)
if (x[i] == 'а' || x[i] == 'б') x.insert(x.begin() + i, x[i]);
std::cout << x;
return 0;
}
- 24.01.2018 01:55
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.