Вопрос по информатике:
Написать программу ,которая на вход получает число p.на входе определяет колличество его четных и нечетных делителей
C++
- 24.11.2017 08:53
- Информатика
- remove_red_eye 19653
- thumb_up 10
Ответы и объяснения 1
#include
int main() {
int x, c=0, odd=0;
std::cin >> x;
for (int i = 1; i<=x; i++)
if (!(x%i)) {
c++;
if(i%2)
odd++;
}
std::cout << c - odd << " HE: " << odd << std::endl;
return 0;
}
- 25.11.2017 13:19
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.