Вопрос по информатике:
составить программу вычисления суммы цифр введенного с клавиатуры 3- х значного натурального числа . Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
- 14.05.2018 10:53
- Информатика
- remove_red_eye 18402
- thumb_up 37
Ответы и объяснения 2
Program gt;
var n,s:integer;
begin
readln(n);
s:=(n div 100)+(n div 10)mod 10+(n mod 10);
writeln(s);
end.
каждая скобка это 1 2 3 цифра соответсвенно
- 15.05.2018 01:53
- thumb_up 51
Var a,N,sum:word;
begin
Read (N);
Sum:=0;
While N0 do
begin
a:=N mod 10;
N:=N div 10;
Sum:=sum+a;
end;
Write (sum);
end.
Или по-простому еще так:
Var a,b,c,N:word;
begin
Read (N);
a:=N mod 10;
b:=(N mod 100) div 10;
c:=N div 100;
Write (a+b+c);
end.
- 16.05.2018 07:33
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.