Вопрос по информатике:
Составить программу на языке паскаль
задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали
- 14.07.2018 22:27
- Информатика
- remove_red_eye 8770
- thumb_up 20
Ответы и объяснения 1
Var n, i, j, ans : integer;
a : array[,] of integer;
begin
read(n);
ans := 0;
SetLength(a, n + 1, n + 1);
for i := 1 to n do
for j := 1 to n do
read(a[i, j]);
for i := 1 to n do
for j := i + 1 to n do
if (a[i, j] > 0) then
ans := ans + 1;
writeln(ans);
end.
- 15.07.2018 21:48
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.