Вопрос по информатике:
Помогите, пожалуйста написать программу на паскаль
Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).
- 01.11.2017 18:15
- Информатика
- remove_red_eye 1539
- thumb_up 44
Ответы и объяснения 1
Var n, digit, ans : integer;
begin
read(n);
ans := 0;
while (n > 0) do begin
digit := n mod 10;
if ((digit = 1) or (digit = 3) or (digit = 9)) then
ans := ans + 1;
n := n div 10;
end;
writeln(ans);
end.
- 02.11.2017 11:32
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.