Вопрос по информатике:
Напишите программу на языке Pascal.Элементы массива А, удовлетворяющие условию А(i)>5.5, переписать в массив В, а элементы, удовлетворяющие условию А(i)<=5.5, переписать в массив С. В массиве А m элементов.
- 19.09.2018 12:41
- Информатика
- remove_red_eye 1510
- thumb_up 18
Ответы и объяснения 1
var
A,B,C: array[1..100] of integer;
i,n,j,k:integer;
begin
randomize;
j:=0;
k:=0;
Readln(n);
Writeln('Исходный массив:');
for i:=1 to n do
begin
A[i]:=random(10);
writeln('A[',i,']=',A[i]);
end;
for i:=1 to n do
if A[i]>5.5
then
begin
j:=j+1;
B[j]:=A[i];
end;
for i:=1 to n do
if A[i]<=5.5
then
begin
K:=k+1;
C[k]:=A[i];
end;
for i:=1 to j do
writeln('B[',i,']=', B[i]);
for i:=1 to k do
writeln('C[',i,']=', C[i]);
end.
- 20.09.2018 04:50
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.