Вопрос по информатике:
Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексами от n до m включительно. Числа n и m введите с клавиатуры.
- 14.12.2017 14:47
- Информатика
- remove_red_eye 4271
- thumb_up 28
Ответы и объяснения 1
Var
a: array [1..10] of integer;
s,i,m,n:integer;
begin
randomize;
for i := 1 to 10 do begin
a[i] := random(10)+1;
write(a[i], ' ');
end;
write(#13+#10+'n = '); readln(n);
write('m = '); readln(m);
if n < 1 then n := 1;
if m > 10 then m := 10;
s := 0;
for i := n to m do s := s + a[i];
writeln('S[',n,'..',m,']=',s );
end.
- 15.12.2017 15:55
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.