Вопрос по информатике:
ПОЖАЛУЙСТА ПОМОГИТЕ ОЧЕНЬ НУЖНО!!!
Натуральные числа А и В являются числителем и
знаменателем обыкновенной дроби. Сократить эту дробь, написать программу на СИ
- 23.02.2017 17:21
- Информатика
- remove_red_eye 1092
- thumb_up 31
Ответы и объяснения 1
#include
#include
#include
int main()
{
setlocale(LC_ALL, "Russian");
int a, b;
int n;
std::cout << "Введите числитель: ";
std::cin >> a;
std::cout << "Введите знаменатель:";
std::cin >> b;
n = a < b ? a:b;
for(int i=1; i<=n; i++)
if(!(a%i) && !(b%i))
{
a/=i;
b/=i;
}
std::cout << " " << a << " \n" << "---";
if(b == 1) std::cout << " = " << a;
std::cout << "\n " << b << " \n";
system("pause");
return 0;
}
- 24.02.2017 00:41
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.