Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающиеся на 3. Кол-во чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число - сумму чисел, оканчивающихся на 3.
- 25.09.2018 02:50
- Информатика
- remove_red_eye 20186
- thumb_up 34
Ответы и объяснения 1
Program A;
var a,b,c,s:integer;
begin
write('введите кол-во чисел в последовательности:');
readln(a);
for c:=1 to a do
begin
write('введите число:');
readln(b);
if (b mod 10=3) then
s:=s+b;
write(b,' ');
end;
writeln('сумма чисел, оканчивающихся на 3=',s);
end.
с клавиатуры вводится кол-во чисел в последовательности и каждое число послед-ти на экран выводится последовательность чисел через пробел и сумму чисел, оканчивающихся на 3
program B;
var a,b,s:integer;
begin
write('введите кол-во чисел в последовательности:');
readln(a);
for c:=1 to a do
b:=random(300)+1;
if (b mod 10=3) then
s:=s+b;
write(b,' ');
end;
writeln('сумма чисел, оканчивающихся на 3=',s);
end.
с клавиатуры вводится только кол-во чисел в последовательности а каждое число послед-ти вводится само рандомно. на экран выводится последовательность чисел через пробел и сумму чисел, оканчивающихся на 3
- 26.09.2018 00:38
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.