Вопрос по информатике:
Дано натуральное число. Найти число, получаемое из
исходного перестановкой его первой и последней цифр.Написать программу в среде devc++ или c++, пожалуйста люди.
- 10.01.2016 22:37
- Информатика
- remove_red_eye 12366
- thumb_up 29
Ответы и объяснения 1
Данная задача достаточно легко реализуется с помощью строкового типа.
#include
#include
int main() {
char number[1000]; std::cin >> number;
int first = number[0]; int second = number[strlen(number)-1];
number[0]=second; number[strlen(number)-1]=first;
std::cout << number;
return 0;
}
- 11.01.2016 12:42
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.