Вопрос по информатике:
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат.Задача 2) Дано целое число. Написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, противном случае.Задача 3) Дано целое число n. Написать программу увеличивающую его на 10, если число больше 0.
- 25.09.2018 12:17
- Информатика
- remove_red_eye 18232
- thumb_up 11
Ответы и объяснения 1
Задача 1
var
a,b:Integer;
Begin
Read(a,b);
if (a>b) then Writeln(b)
else if (a else Writeln('Числа равны');
end.
Задача 2
var
n:Integer;
Begin
Read(n);
if (n<0) then Writeln(0)
else Writeln(n);
end.
3адача 3.
var
n:Integer;
Begin
Read(n);
if (n>0) then Writeln(n+10)
else Writeln(n);
end.
- 26.09.2018 01:07
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.