Вопрос по информатике:
Помогите пожалуйста надо составить программу в ПАСКАЛЕ. Известны координаты трех точек A(x1,y1), B(x2,y2), C(x3,y3). Найти расстояние АС+АВ.
- 13.02.2018 13:26
- Информатика
- remove_red_eye 3573
- thumb_up 30
Ответы и объяснения 1
Var
x1, x2, x3, y1, y2, y3, L: real;
begin
Write('Введите через пробел координаты точки А: ');
Readln(x1, y1);
Write('Введите через пробел координаты точки B: ');
Readln(x2, y2);
Write('Введите через пробел координаты точки C: ');
Readln(x3, y3);
L := sqrt(sqr(x2 - x1) + sqr(y2 - y1)) + sqrt(sqr(x3 - x1) + sqr(y3 - y1));
Write('Сумма длин AB+AC равна ', L:0:3)
end.
Тестовое решение:
Введите через пробел координаты точки А: -3 2
Введите через пробел координаты точки B: 4.3 1.8
Введите через пробел координаты точки C: 0 7
Сумма длин AB+AC равна 13.134
- 14.02.2018 09:27
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.