Вопрос по информатике:
Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число на входе и выводит сумму его цифр.
Я написал первую часть программы (без вывода суммы цифр) :
program sg3;
uses crt;
var i,a,k: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then k:=k+1;
if k=0 then write('Простое')
else writeln('Составное');
readln;
end.
Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль
- 20.08.2017 08:00
- Информатика
- remove_red_eye 4844
- thumb_up 26
Ответы и объяснения 1
Program sg3;
uses crt;
var i,a,k, sum: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then
k:=k+1;
if k=0 then
write('Простое')
else
writeln('Составное');
while (a0) do
begin
sum:=sum+(a mod 10);
a:=a div 10;
end;
write('Сумма цифр= ',sum);
end.
- 21.08.2017 09:02
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.