Вопрос по информатике:
Написать программу, которая проверяет, является ли введённая с
клавиатуры строка шестнадцатеричным числом. В Паскале.
- 14.05.2018 11:09
- Информатика
- remove_red_eye 19021
- thumb_up 19
Ответы и объяснения 2
Не понравилась реализация, переделал, специально сохранив основу предыдущего решения.
const
legal = ['0'..'9', 'A'..'F', 'a'..'f'];
var
s: string;
i: integer;
IsHex: Boolean;
begin
writeln('Введите строку: ');
readln(s);
i := 1;
IsHex := True;
while (i <= length(s)) and IsHex do
begin
if not (s[i] in legal) then IsHex := False;
i := i + 1
end;
if isHex then
writeln('Введенная строка является шестнадцатиричным числом.')
else
writeln('Введенная строка не является шестнадцатиричным числом.');
end.
Тестовое решение:
Введите строку:
58bfa
Введенная строка является шестнадцатиричным числом.
Введите строку:
1054Acg
Введенная строка не является шестнадцатиричным числом.
- 16.05.2018 11:23
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.