Вопрос по информатике:
Составить программу на языке паскаль. Составить блок схему.
Дан массив вещественных чисел. Ко всем отрицательным элементам прибавить элемент с номером , к остальным - элемент с номером
.
- 09.05.2015 07:43
- Информатика
- remove_red_eye 16712
- thumb_up 17
Ответы и объяснения 1
Const
m=10;
var
i,s,n,m1,m2:integer;
a:array[1..m]of integer;
begin
write('Исходный массив: ');
for i:=1 to m do
begin
a[i]:=random(-5,10);
write(a[i],' ');
end;
writeln;
repeat
write('Введите m1 и m2: ');
readln(m1,m2);
until (m1>0) and (m2>0) and (m1<=m) and (m2<=m);
n:=a[m1];
s:=a[m2];
write('Измененный массив: ');
for i:=1 to m do
begin
if a[i]<0 then a[i]:=a[i]+n
else a[i]:=a[i]+s;
write(a[i],' ');
end;
end.
- 01.01.1970 00:00
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.