Вопрос по информатике:
Написать программу для паскаль.С клавиатуры вводятся целые числа.Признаком конца ввода является 0.Изменить знак отрицательных чисел на противоположный.Результаты вывести на экран.
- 10.01.2018 15:40
- Информатика
- remove_red_eye 19344
- thumb_up 33
Ответы и объяснения 2
Предложу решение, основанное на том, что понял из текста)
var a: integer;
begin
writeln('Вводите числа');
a:=1;
while a0 do begin
readln(a);
if a<0 then writeln('Противоположное число ',abs(a));
end;
readln
end.
Можно их в массив записывать, если нужно вывести красиво.
- 11.01.2018 01:11
- thumb_up 35
Var n: integer;
s: string;
begin
writeln('Вводите числа');
repeat
readln(n);
s:= s + IntToStr(abs(n)) + ' '
until n = 0;
writeln(s);
end.
- 12.01.2018 16:59
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.