Вопрос по информатике:
Помогите пожалуйста составить программу на ''Pascal ABC'')
Дана строка, содержащая текст на русском языке, и некоторая буква. Подсчитать, сколько слов начинается с указанной буквы.
- 22.04.2018 07:51
- Информатика
- remove_red_eye 17589
- thumb_up 17
Ответы и объяснения 1
Var s:string;i,f,l:integer;a:string;
begin
readln(s);
read(a)
;f:=0;
l:=length(s);
for i:=l downto 1 do
begin
if s[i]=' ' then
if s[i+1]='a' then f:=f+1;
end;
if s[1]='a' then f:=f+1;
writeln(f);
end.
- 23.04.2018 09:27
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.