Вопрос по информатике:
Дан одномерный массив D ,размерностью 20. Элементы массива - это целые числа из промежутка [0;750]. Напишите программу в Паскале ,вычисляющую количество элементов массива больших 500, которые кратны числу 15.
- 24.03.2018 00:42
- Информатика
- remove_red_eye 16423
- thumb_up 12
Ответы и объяснения 1
const
n=20;
var
i,k,e:integer;
a:array[1..n] of integer;
begin
Randomize;
k:=0;
for i:=1 to n do begin
e:=random(750);
a[i]:=e;
if (e>500) and (e mod 15 =0) then
k:=k+1;
write(e:4)
end;
writeln;
writeln('Найдено чисел: ',k);
end.
Тестовый пример:
262 743 705 288 545 694 437 280 317 434 53 344 302 293 246 200 608 194 523 478
Найдено чисел: 1
- 25.03.2018 18:34
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.