Вопрос по информатике:
Составьте программу,которая вводит трехзначное число и выводит число, образованное при перестановке цифр в обратном порядке (например:123-321). В Паскале. Помогите пожалуйста! Спасибо заранее!
- 07.11.2017 18:25
- Информатика
- remove_red_eye 9213
- thumb_up 24
Ответы и объяснения 1
Var
a:longint;
s:string;
i:integer;
begin
writeln('Введите целое положительное число');
readln(a);
Str(a,s);
write('Результат: ');
for i:= length(s) downto 1 do
write(s[i]);
writeln
end.
Тестовый пример:
Введите целое положительное число
1234567890
Результат: 0987654321
- 08.11.2017 09:27
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.