Вопрос по информатике:
Написать программу которая складывает числа до тех пор пока не получится число состоящее из одной цифры.
пример:
5+5+5=15=1+5=6
он должен ответ складывать так как показано в примере как это сделать я не как не могу понять(
- 20.02.2018 15:38
- Информатика
- remove_red_eye 19682
- thumb_up 41
Ответы и объяснения 1
Var
a, b: integer;
begin
readln(a);
while (inttostr(a).Length > 1) do
begin
b := 0;
foreach c: char in inttostr(a) do
b += strtoint(c);
a := b;
end;
writeln(b);
end.
=======================
var
a, b, e: integer;
d: string;
begin
readln(a);
d := inttostr(a);
while (length(d) > 1) do
begin
d := inttostr(a);
b := 0;
for e := 1 to length(d) do
b += strtoint(d[e]);
a := b;
end;
writeln(b);
end.
- 22.02.2018 00:26
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.