Вопрос по информатике:
Написать программу, которая вычисляет факториал числа, введенного с клавиатуры (используя цикл с параметром).
язык - pascal
- 19.07.2018 14:54
- Информатика
- remove_red_eye 4470
- thumb_up 50
Ответы и объяснения 2
Program E9;
var p, i, n: integer;
begin
write ('введите целое n = ');
readln (n);
p: = 1;
for i: = 1 to n do
p: = p * i;
write (n, '! = ',p);
readln
end.
- 20.07.2018 20:55
- thumb_up 10
Var
y: System.uint64; //Большая цЫфра же и положительная
x, i: byte; //Нет смысла большие числа брать слишком, переполнение будет
begin
readln(x); //Принимаем число...
y := 1;
for i := 1 to x do
y *= i; //...и умножаем такое-то количество раз
if (y = 0) then //Выводим, предусмотрев переполнение
writeln('Слишком большая цЫферка')
else
writeln(y);
end.
==========================================
Int64 - это то же самое, что LongInt, а Uint64 (unsign long int) - длинное число без знака, при правильном использовании позволяет записывать в переменную числа, в 2 раза превышающие максимум Int64
- 21.07.2018 10:36
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.