Вопрос по информатике:
Написать программу для Паскаль
Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. Программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.
- 17.06.2018 11:22
- Информатика
- remove_red_eye 1957
- thumb_up 7
Ответы и объяснения 1
var
m, k, d1: single;
i, t, d: byte;
begin
readln(t);
writeln();
for i := 1 to t do
begin
readln(k);
if (k > 0) then
begin
d1 += k;
d += 1;
end;
end;
writeln(d1 / d);
end.
- 18.06.2018 12:27
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.