Вопрос по информатике:
Помогите решить задачу в паскаль!!!
Последовательность состоит из натуральных чисел и завершается числом 0. Всего вводится не более 10000 чисел (не считая завершающего числа 0). Определите, сколько элементов этой последовательности равны ее наибольшему элементу.Числа, следующие за числом 0, считывать не нужно.
у меня есть такой вариант но нужен еще один
readln(a);begin
if a > 0 then
if (max = 0) or (a > max) then
begin
max := a;
k := 1 end
else if a = max then
inc(k);
end;
until a=0;
write(k);
end.
- 13.02.2018 16:13
- Информатика
- remove_red_eye 19324
- thumb_up 17
Ответы и объяснения 1
Var t,i,x,max:integer;
begin
max:=0;t:=0;
repeat
begin
x:=0;
read(x);
if (x>0) and (x=max) then i:=i+1;
if x>max then
begin
max:=x;
i:=1;
end;
t:=t+1;
end;
until (x=1000) or (x mod 1>0);
if (x0) then begin i:=-1; writeln('Нельзя вводить ненатуральные числа');end;
if i=0 then writeln('Введён только ноль');
if i>0 then writeln('Чисел, равных максимуму: ', i);
end.
- 14.02.2018 17:04
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.