Вопрос по информатике:
Напишите программу в паскале на нахождение суммы главных диагоналей для квадратной матрицы. Помогите, пожалуйста
- 23.05.2018 14:17
- Информатика
- remove_red_eye 12365
- thumb_up 20
Ответы и объяснения 1
Program matrica;
Uses crt;
Var a:array [0..8 , 0..8] of integer;
sum1,sum2,i,j:integer;
begin
randomize;
sum1:=0;
sum2:=0
for i:=1 to 8 do
begin
Writeln;
for j:=1 to 8 do
begin
a[i"j]:=random(10);
if i=j then sum1:=sum1+a[i,j];
if i+j=9 then sum2:=sum2+a[i,j];
Write(a[i,j], ' ');
end;
end;
writeln('Сумма чисел первой диагонали -',sum1,' 'Сумма чисел второй диагонали' ,sum2,');
end.
- 24.05.2018 22:29
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.