Вопрос по информатике:
Арбуз диаметром Д1 см стоит на рынке С1 руб за кг,а арбуз диаметром Д2 см стоит С2 руб за кг.Толщина корки арбуза Т мм.Составить программу,сообщающую,какой арбуз выгоднее купить.Плотность мякоти и корки считать равными.
- 24.09.2017 19:45
- Информатика
- remove_red_eye 19223
- thumb_up 39
Ответы и объяснения 2
(Д1 - (С1+Т1)) - (Д2 - (С2 +Т2)).Если > 0, то выгоднее купить первый арбуз
Если < 0, то выгоднее купить второй арбуз
- 25.09.2017 13:05
- thumb_up 22
Var
d1,d2,t,c1,c2,s1,s2: real;
begin
write('Диаметр 1-го арбуза (см): ');
readln(d1);
write('Цена за кг 1-го арбуза: ');
readln(c1);
write('Диаметр 2-го арбуза (см): ');
readln(d2);
write('Цена за кг 2-го арбуза: ');
readln(c2);
write('Толщина корки (мм): ');
readln(t);
t:=t/10;
s1:=c1*power(d1/2,3)/(power((d1/2-t),3)); //стоимость ед.мякоти 1
s2:=c2*power(d2/2,3)/(power((d2/2-t),3)); //стоимость ед.мякоти 2
if s1
end.
- 26.09.2017 20:17
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.