Вопрос по информатике:
C начала 1990 года по некоторый день прошло n месяцев и 2 дня. Определить название месяца этого дня, написать программу в pascal (case of) и (if else), подскажите хотя бы алгоритм решения!
- 20.07.2018 02:37
- Информатика
- remove_red_eye 13623
- thumb_up 38
Ответы и объяснения 1
Var
A: System.DateTime;
i: byte;
begin
readln(i);
A := (new System.DateTime(1990, 1, 1)).AddMonths(i).AddDays(2);
case A.DayOfWeek of
System.DayOfWeek.Monday: writeln('ПН');
System.DayOfWeek.Tuesday: writeln('ВТ');
System.DayOfWeek.Wednesday: writeln('СР');
System.DayOfWeek.Thursday: writeln('Чт');
System.DayOfWeek.Friday: writeln('ПТ');
System.DayOfWeek.Saturday: writeln('СБ');
System.DayOfWeek.Sunday: writeln('ВС');
end;
end.
- 21.07.2018 18:35
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.