Вопрос по информатике:
Написать программу чтоб работала в Pascal
запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколь-ко из них отрицательных, положительных и нулевых.
- 19.03.2018 01:32
- Информатика
- remove_red_eye 15053
- thumb_up 19
Ответы и объяснения 2
PascalABC
var x,y,z:real;
k,m,n:integer;
begin
k:=0;
m:=0;
n:=0;
writeln('Введите первое число');
readln(x);
writeln('Введите второе число');
readln(y);
writeln('Введите третье число');
readln(z);
if x>0 then k:=k+1
else if x=0 then m:=m+1
else n:=n+1;
if y>0 then k:=k+1
else if y=0 then m:=m+1
else n:=n+1;
if z>0 then k:=k+1
else if z=0 then m:=m+1
else n:=n+1;
writeln('Количеcтво положительных чисел : ',k);
writeln('Количеcтво нулевых чисел : ',m);
writeln('Количеcтво отрицательных чисел : ',n);
end.
- 20.03.2018 00:34
- thumb_up 1
Program pr; var a,b,nul,otr,pol,c:integer; begin write('A='); readln(a); write('B='); readln(b); write('C='); readln(c); if a>0 then pol:=pol+1 else if a=0 then nul:=nul+1 else otr:=otr+1; if b>0 then pol:=pol+1 else if b=0 then nul:=nul+1 else otr:=otr+1; if c>0 then pol:=pol+1 else if c=0 then nul:=nul+1 else otr:=otr+1; writeln('Положительных: ',pol); writeln('Отрицательных: ',otr); writeln('Нулевых: ',nul); end.
- 21.03.2018 18:02
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.