Вопрос по информатике:
Напишите программу, запрашивающую три стороны треугольника А, В, С и вычисляющую его площадь по формуле Герона
- 11.10.2017 05:25
- Информатика
- remove_red_eye 1443
- thumb_up 41
Ответы и объяснения 1
Если паскаль, то форму сам знаешь как, наверное вот тебе тело.
var p,S,AB,BC,AC :real(если не работает, то Integer);
begin
readln(AB);
readln(BC);
readln(AC);
p:=(AB+BC+AC)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
Writeln(s)
end.
Поправь там знаки или ещё что-нибудь - я не в программе писал.
- 12.10.2017 10:59
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.