Вопрос по информатике:
Напишите программу на языке паскаль
как найти корни квадратного уравнения ( ax+bx+c=0 ),при этом использовав if then else со значениями дискрименанта D=0 D<0 b D>0
- 27.05.2016 22:40
- Информатика
- remove_red_eye 15190
- thumb_up 9
Ответы и объяснения 1
a, b, c, D: real;
x1, x2: real;
begin
Write('Введите А:'); Readln(a);
Write('Введите B:'); Readln(b);
Write('Введите C:'); Readln(c);
D := sqr(b) - (4 * a * c);
if (D > 0) then
begin
x1 := (-b + sqrt(D)) / (2 * a);
x2 := (-b - sqrt(D)) / (2 * a);
Writeln('x1=', x1);
Writeln('x2=', x2); end else
if(d = 0) then
begin
x1 := b / (2 * a);
Write('x1=', x1, 'x2=', x1);
end else
writeln('Корней нет');
end.
- 28.05.2016 07:13
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.