Вопрос по информатике:
написать программу которая по вводу с клавиатуры трех действительных чисел выводит на экран сообщение о том могут ли они являться сторонами треугольника
- 23.11.2017 01:05
- Информатика
- remove_red_eye 7340
- thumb_up 28
Ответы и объяснения 1
Нужно воспользоваться свойством треугольников:
Любая сторона треугольника меньше суммы двух других сторон и больше их разности .
---------------------------------------------------Pascal--------------------------------------------------
Var a,b,c:integer;
begin
readln(a,b,c);
if (ab-c) and (ba-c) and (cb-a) then
writeln('Yes')
else
writeln('No');
end.
- 24.11.2017 21:05
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.