Вопрос по информатике:
ПАСКАЛЬ
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.
- 09.10.2017 05:14
- Информатика
- remove_red_eye 7934
- thumb_up 32
Ответы и объяснения 1
Var a:array[1..100] of integer;
i,p,m:integer;
begin
p:=0;
m:=0;
for i:=1 to 100 do begin
a[i]:=random(-20,20);
if a[i]>0 then p+=1 else
m+=1;
end;
writeln('Положительных - ',p,' отрицательных - ',m);
end.
- 01.01.1970 00:00
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.