Вопрос по информатике:
Составьте программу для нахождения количества чисел, кратных 3
и 5 в интервале от 300 до 1000.
- 24.01.2015 08:05
- Информатика
- remove_red_eye 19660
- thumb_up 45
Ответы и объяснения 2
Excel программа, которая выводит количество чисел кратных 3, 5, 3и5
Sub krat()
S3 = 0
S5 = 0
S35 = 0
For i = 300 To 1000
If i / 3 = Int(i / 3) Then
S3 = S3 + 1
End If
If i / 5 = Int(i / 5) Then
S5 = S5 + 1
End If
If i / 5 = Int(i / 5) And i / 3 = Int(i / 3) Then
S35 = S35 + 1
End If
Next i
Cells(2, 2) = S3
Cells(3, 2) = S5
Cells(4, 2) = S35
End Sub
- 25.01.2015 06:48
- thumb_up 5
Var k, numb, count:integer;
begin
for k:= 300 to 1000 do
if (k mod 3 = 0) and ( k mod 5 = 0) then
count:= count + 1;
writeln(count);
end.
- 26.01.2015 12:22
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.