Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет
- 19.03.2018 07:03
- Информатика
- remove_red_eye 8304
- thumb_up 43
Ответы и объяснения 1
Var summa,count,numb :integer;
begin
summa:=0;
count:=0;
readln(numb);
while numb 0 do
begin
if numb mod 17 = 0 then
begin
summa:=summa+numb;
count:=count+1;
end;
readln(numb);
end;
if (summa > 0) and (count > 0) then
writeln(summa,' ',count)
else
writeln('No');
end.
- 20.03.2018 22:35
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.