Вопрос по информатике:
Доброго времени суток. Пожалуйста, помогите составить программу в Паскале.
Дана последовательность вещественных чисел, содержащих n=15 элементов. Построить из неё новую последовательность, так чтобы в её начале располагались все отрицательные, а затем все положительные числа и нули. Относительный порядок расположения как отрицательных, так и не отрицательных должен быть сохранён
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 26.01.2016 14:10
- Информатика
- remove_red_eye 5845
- thumb_up 29
Ответы и объяснения 1
Var
res,mas:array[1..100] of real;
k,i:integer;
begin
k:=0;
for i:=1 to 15 do
read(mas[i]);
for i:=1 to 15 do
begin
if mas[i]<0 then
write(mas[i],' ')
else
begin
k:=k+1;
res[k]:=mas[i];
end;
end;
for i:=1 to k do
write(res[i],' ');
end.
- 27.01.2016 20:01
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.