Вопрос по информатике:
Построить блок-схему и написать программу
1. Вычислить S=1+2+3+4+…+N
2. Для данного N составить алгоритм вычисления факториала N!=1*2*3*…*N
- 28.11.2017 00:34
- Информатика
- remove_red_eye 5746
- thumb_up 41
Ответы и объяснения 1
1.
program z;
var n,i:integer; s:real;
begin
writeln('Введите число n'); readln(n);
for i:=1 to n do
begin
s:= (n*(n+1))/2; end;
writeln(s);
end.
2. program z2;
var s,i,n:integer;
begin
writeln('Введите число n '); readln (n);
s:=1;
for i:=1 to n do s:=s*i;
write(s); end.
- 28.11.2017 05:48
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.