Вопрос по информатике:
Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение
- 11.04.2018 18:00
- Информатика
- remove_red_eye 4361
- thumb_up 9
Ответы и объяснения 1
Program p1;
const n=10;
var a:array [1..n] of real;
i:byte;
max:real;
nmax:byte;
begin
//начало цикла ввода
For i:=1 to n do
//ввод
Readln(a[i])
//берём за максимальный 1ый элемент
max:=a[1];
//берём количество = 1
nmax:=1; /
/начало цикла проверки
For i:= 2 to n do
if a[i]> max then
begin
max:=a[i];
nmax:=1;
end else
if a[i]= max then
nmax:=nmax+1;
//вывод
Writeln('Максимальный элемент = ', max,', количество таких элементов = ',nmax); end.
- 12.04.2018 04:38
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.