Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму нечетных чисел, меньших 40. программа получает на вход количество чисел в последовательности, а затем сами числа. кол-во чисел не превышает 1000. введеные числа не превышают 30000. программа должна вывести одно число - сумму нечетных чисел, меньших 40. пример работы программы:входные данные 3 21 54 37 выходные данные 58. Pascal ABC
- 06.07.2015 13:10
- Информатика
- remove_red_eye 19279
- thumb_up 39
Ответы и объяснения 1
begin
readln(n);
s:=0;
for i:=1 to n do
begin
readln(a);
if (a mod 2=1)and(a<40) then s:=s+a;
end;
writeln(s);
end.
Пример:
3
21
54
37
58
- 07.07.2015 10:11
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.