Вопрос по информатике:
Написать программу в паскале:
Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа.
- 25.09.2016 21:37
- Информатика
- remove_red_eye 12663
- thumb_up 15
Ответы и объяснения 2
Var a,b,c,n:integer;beginreadln(n);{находим 1 цифру}a:=n mod 10;b:=n div 10 mod 10 ;c:= n div 100;n:=100*a + 10*b + c;writeln(n);end.
- 26.09.2016 09:15
- thumb_up 40
Другой способ:
var a,i:longint;
begin
readln(a);
for i:=1 to 3 do
begin
write(a mod 10);
a:=a div 10;
end;
end.
- 27.09.2016 07:44
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.