Вопрос по информатике:
Составить программу, выводящую количество корней квадратного уравнения
- 04.10.2017 12:14
- Информатика
- remove_red_eye 5917
- thumb_up 49
Ответы и объяснения 2
Var a,b,c:integer; q:real;beginwriteln ('a*x^2+b*x+c');writeln ('vvedite a');readln (a);writeln ('vvedite b');readln (b);writeln ('vvedite C');readln (c);q:=b*b-4*a*c;If q>0 then writeln (2);If q=0 then writeln (1);If q<0 then writeln (0);end.
- 05.10.2017 20:19
- thumb_up 25
Var
a,b,c:integer;
q:real;
Begin
Writeln ('a*x^2+b*x+c');
Write('Введите A: '); readln(a);
Write('Введите B: '); readln(b);
Write('Введите C: '); readln(c);
q:=b*b-4*a*c;
if q>0 then writeln ('2 корня');
if q=0 then writeln ('1 корень');
if q<0 then writeln ('0 корней');
End.
- 06.10.2017 14:49
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.