Вопрос по информатике:
Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отриц
- 27.01.2018 01:14
- Информатика
- remove_red_eye 4430
- thumb_up 7
Ответы и объяснения 2
Var a,b,p,n:integer;
begin
writeln ('Введите два числа:');
readln (a, b);
n:=abs(b);
if (a=0) or (b=0) then
writeln (a,'*',b,'=0')
else begin
while (n0) do begin
n:=n-1;
p:=p+abs(a)
end;
if (a>0) and (b>0) then writeln (a,'*',b,'=',p);
if (a<0) and (b<0) then writeln ('(',a,')','*','(',b,')','=',p);
if (a>0) and (b<0) then writeln (a,'*','(',b,')','=-',p);
if (a0) then writeln ('(',a,')','*',b,'=-',p);
end;
end.
- 28.01.2018 21:21
- thumb_up 47
//PascalABC.NET версия 3.3.1590 от 03.12.2017
//Если программа не запускается, то обновите версию
var
a, b, i, p: integer;
begin
readln(a, b);
p := 0;
for i := 1 to abs(b) do
p := p + abs(a);
if sign(a) sign(b) then p := -p;
writeln(p);
end.
- 29.01.2018 04:44
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.