Вопрос по информатике:
Дано натуральное число.Определите количество цифр в нём.( в Паскаль)
- 07.12.2015 11:18
- Информатика
- remove_red_eye 17739
- thumb_up 47
Ответы и объяснения 1
Более честный способ:
uses crt;
var s,ans:integer;
begin
read(s);
while s>0 do
begin
inc(ans);
s:=s div 10;
end;
writeln(ans);
end.
Более короткий:
uses crt;
var s:string;
begin
read(s);
writeln(length(s));
end.
- 08.12.2015 17:01
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.